Mail1 Maintenance
Incident Report for GearHost
Resolved
This has been completed.
Posted 6 months ago. Jan 31, 2018 - 05:44 UTC
Monitoring
We will be making some configuration changes to the mail server which are important to ensure stability. The downtime is expected to take 10 - 30 minutes.
Posted 6 months ago. Jan 31, 2018 - 05:18 UTC