Mail1 outage
Incident Report for GearHost
Resolved
This incident has been resolved.
Posted over 1 year ago. Feb 08, 2018 - 14:47 MST
Monitoring
We're currently working on restoring the service back on this mail server environment.
Posted over 1 year ago. Feb 08, 2018 - 13:33 MST