Mail1 Server Issue
Incident Report for GearHost
Resolved
mail1 is now fully functional. We apologize for this inconvenience. If you are still experiencing issues please create a ticket.
Posted 23 days ago. Dec 28, 2017 - 19:14 UTC
Investigating
We are looking into mail1 SMTP issues. We will update you once we have a resolution.
Posted 23 days ago. Dec 28, 2017 - 18:40 UTC