Mail Server Updates
Incident Report for GearHost
Resolved
All mail servers have been updated, we appreciate your patience.
Posted 10 months ago. Dec 14, 2017 - 04:10 UTC
Monitoring
We will begin updating our mail servers. The expected downtime is expected to take 5 - 10 minutes per server.
Posted 10 months ago. Dec 14, 2017 - 03:55 UTC