Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 04, 2021 - 23:45 MDT
Scheduled
Our network team will be working on upgrades for the core switches. There will be some intermittent connection issues during the time of this maintenance window. Downtime should be less than 10 to 15 minutes.
Posted Aug 31, 2021 - 11:53 MDT
This scheduled maintenance affected: DEN1, API, CloudSites, Control Panel, Databases, DNS, and Email.