Mail Server Updates
Incident Report for GearHost
Resolved
Updates have been completed, we appreciate your patience!
Posted over 1 year ago. Mar 07, 2018 - 01:22 MST
Monitoring
We will be performing updates on mail1 and mail2. The expected downtime is 3 - 10 minutes.
Posted over 1 year ago. Mar 07, 2018 - 01:07 MST