mail1
Incident Report for GearHost
Resolved
The issues have been resolved with our mail1 server. We will be doing maintenance tonight to fix the reoccurring problems.
Posted over 1 year ago. Feb 06, 2018 - 15:03 MST
Investigating
We are currently investigating the issues on our mail1 server. An update will be provided when we have more information.
Posted over 1 year ago. Feb 06, 2018 - 11:31 MST