Mail2
Incident Report for GearHost
Resolved
The issue has been resolved. If you are still expierencing issues please open a support ticket by emailing support@gearhost.com
Posted Oct 18, 2017 - 15:04 MDT
Investigating
Our team is currently investigating the Mail2 server. We are sorry for any inconvenience this causes, we will have this solved shortly.
Posted Oct 18, 2017 - 14:26 MDT