Mail Server Updates
Incident Report for GearHost
Resolved
All mail servers have been successfully updated. We appreciate your patience!
Posted Oct 16, 2017 - 23:39 MDT
Monitoring
We will be performing another quick patch on our mail servers. They will be unavailable for 5 - 15 minutes.
Posted Oct 16, 2017 - 23:25 MDT