Mail4 server minor outage
Incident Report for GearHost
Resolved
mail4 service has been restored. Thank you for your patience.,
Posted 4 months ago. Jan 26, 2018 - 22:32 UTC
Monitoring
Our mail4 server is experiencing issues right now, we're working to get this resolved as soon as possible.
Posted 4 months ago. Jan 26, 2018 - 22:00 UTC