Mail Server Updates
Incident Report for GearHost
Resolved
All updates were successfully installed. We appreciate your patience!
Posted 11 months ago. Dec 08, 2017 - 06:44 UTC
Monitoring
We will be performing another round of updates. The expected downtime is 3 - 10 minutes depending on each server.
Posted 11 months ago. Dec 08, 2017 - 06:10 UTC