mail4
Incident Report for GearHost
Resolved
This incident has been resolved.
Posted over 1 year ago. Feb 08, 2018 - 09:48 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted over 1 year ago. Feb 08, 2018 - 09:42 MST
Identified
The issue has been identified and a fix is being implemented.
Posted over 1 year ago. Feb 08, 2018 - 09:31 MST
Investigating
We are looking into the connection issues on this mail server. Our Admins will have an update shortly.
Posted over 1 year ago. Feb 08, 2018 - 09:29 MST