Mail server updates
Incident Report for GearHost
Resolved
All mail servers are up to date, we appreciate your patience.
Posted 9 months ago. Jan 17, 2018 - 07:38 UTC
Monitoring
Mail servers will be updated shortly, downtime is expected to take 3 - 10 minutes depending on each mail server.
Posted 9 months ago. Jan 17, 2018 - 07:08 UTC