mail1
Incident Report for GearHost
Resolved
This incident has been resolved.
Posted 6 months ago. Feb 07, 2018 - 12:48 UTC
Investigating
We are aware of the issues with our mail1 server. We have an onsite engineer working very hard to get this fixed. An update will be provided once this is resolved.
Posted 6 months ago. Feb 07, 2018 - 12:36 UTC