Mail2 Maintenance
Incident Report for GearHost
Resolved
The server is back up and running, we appreciate your patience.
Posted about 1 month ago. Dec 21, 2017 - 06:55 UTC
Monitoring
We're rebooting mail2 to apply a security update. This is expected to take 3 -5 minutes.
Posted about 1 month ago. Dec 21, 2017 - 06:52 UTC