Mail server updates
Incident Report for GearHost
Resolved
All mail servers have been successfully updated.
Posted about 1 month ago. Sep 16, 2017 - 08:30 UTC
Monitoring
We're updating our mail servers for security enhancements and to fix software bugs. The downtime is expected to last no more than 10 minutes.
Posted about 1 month ago. Sep 16, 2017 - 07:14 UTC