Mail Server Updates
Incident Report for GearHost
Resolved
All mail servers have been successfully updated. We truly appreciate your patience!
Posted Oct 18, 2017 - 23:40 MDT
Monitoring
We're performing mail updates on our mail server environment right now, the expected downtime is 10 - 15 minutes.
Posted Oct 18, 2017 - 22:18 MDT