mail1 Maintenance
Incident Report for GearHost
Resolved
Maintenance for this mail server has been completed. If you have any issues please create a support ticket.
Posted 10 months ago. Feb 02, 2018 - 05:26 UTC
Monitoring
We are performing required maintenance on our mail1 server. We anticipate that this will take 30 minutes. An update will be provided once this is complete.
Posted 10 months ago. Feb 02, 2018 - 05:07 UTC